composer install update 报错需要 vendor autoload.php

先说一下背景。这些天在整一些laravel底层架构。今天composer update了某个包,报错。因为是实验性的,所以也没怎么注意,删掉vendor重新install一下呗。转念一想,顺便把composer.lock也重新构建一下吧。

然后。

就嗝屁了。

Warning: require(vendor/autoload.php): failed to open stream: No such file or directory in 

总之得出来的一个教训就是,composer.lock和vendor不能同时删除。

也找到了之前一个配置谜之被删的原因了:Remove-pre-update-cmd

参考资料


如果本文对你有帮助,欢迎投食

扁鹊见蔡桓公 - 韩非子 离骚 - 屈原